Zanim...
Zanim...

Zanim...


Polskie Forum FPV

Forum modelarzy i pilotów FPV
Dzisiaj jest niedziela 22 lip 2018, 06:16


Strefa czasowa UTC+1godz.




Nowy temat Odpowiedz w temacie  [ Posty: 5 ] 
Autor Wiadomość
Post: poniedziałek 09 lip 2018, 12:22 
Offline

Rejestracja: niedziela 20 wrz 2015, 19:08
Posty: 362
Witam.

Chciałbym zapytać Was o przyczynę powstawania lagów przy przesyłaniu obrazu na telefon.

Sprawa wygląda tak:

Dron: Mavic Pro Platinum - najnowszy firmware w dronie, nadajniku itd
Aplikacja DJI Go - Najnowsza
Telefon- Samsung Galaxy S5 (android 6.0.1)

Podczas lotu a nawet jak dron stoi na ziemi - już pojawiają się "lagi" (opóźnienie w otrzymywanym obrazie) nawet ok 2 sekund. Na ekranie pojawiają się pixele i ogólnie mało co widać - a jeżeli już widać to duże opóźnienie.
W aplikacji sprawdzam jakość połączenia wideo i mam dobrą (próba lotów na łące ok 100 metrów od najbliższych zabudowań) Szybkość przesyłu obrazu w MB waha się od 2 do 5-6, w porywach do 9 mb/s. Zmiana kanałów z auto na manual i wybranie ręczne częstotliwości z wykresu nic nie daje. Tak samo zmiana z 20hz na 10hz. Wczoraj myślałem że to może być kwestia braku miejsca na telefonie (miałem ok 600 mb wolnej przestrzeni w pamięci telefonu). Dzisiaj stan pamięci telefonu to już 1300 mb wolnego miejsca - zero poprawy.
Podczas lotów w telefonie wyłączone dane komórkowe, gps i inne bajery. Próbowałem nawet z opcją trybu samolotowego telefonu - nic to nie dało.
W aplikacji ustawione cache recording na pamięć karty sd. Wyłączyłem cachowanie obrazu - nadal bez zmian. Kiedy zmienię cache na localy to jest jeszcze gorzej - telefon się grzeje i po chwili kończy się dostępna pamięć telefonu.

Co ciekawe kiedy oglądam obraz nagrany przez drona to nie widać pixeli ani opóźnień - wszystko jest ok - czyli nagrywanie wychodzi dobrze - gorzej z przesyłaniem obrazu na żywo.
Wcześniej latałem zawsze na tablecie i nigdy nie miałem problemów ale chwilowo tablet mam w naprawie więc mogę latać tylko na telefonie (sam telefon jest zalecany jako urządzenie dla aplikacji djigo4) więc tutaj też może nie o to chodzi.

Co do samego firmware to ludzie piszą dobre opinie o tym najnowszym więc raczej kwestia firmware odpada.

Jesteście w stanie podać mi waszą prędkość przesyłania obrazu w mb/s ? chciałbym sprawdzić czy jest jakaś znaczna różnica w przesyle obrazu.
Może jeszcze jakaś opcja którą należy włączyć, wyłączyć w samej aplikacji djigo4 ?

Odinstalowałem nawet aplikację DJIGO4 i zainstalowałem ponownie - bez poprawy (ale widzę że dane w aplikacji są zapamiętane więc może trzeba odinstalować i wyczyścić wszystko po djigo4 z telefonu).

Ps po zaktualizowaniu softu w dronie, nadajniku itp itd nie resetowałem ani drona ani nadajnika (ponoć zalecali zresetowanie ale mimo iż aktualizowałem firmware już kilka razy to ani razu nie robiłem tych resetów).

_________________
Mavic Pro Platinum Combo


Na górę
 Wyświetl profil  
 
Post: poniedziałek 09 lip 2018, 12:54 
Offline
Awatar użytkownika

Rejestracja: środa 03 wrz 2014, 11:11
Posty: 8495
Lokalizacja: 50°08′13″N ; 18°57′59″E
Sprawdź na byle jakim (od 5s, lub ipad mini 2) ios i będziesz wiedział gdzie leży problem. Zapytaj znajomych, może ktoś posiada apple.
Obstawiam telefon.

_________________
Mój kanał na YT


Na górę
 Wyświetl profil  
 
Post: poniedziałek 09 lip 2018, 13:42 
Offline

Rejestracja: piątek 27 mar 2015, 11:37
Posty: 210
To chyba sprawka ostatniej aktualizacji.


Na górę
 Wyświetl profil  
 
Post: poniedziałek 09 lip 2018, 13:49 
Offline

Rejestracja: niedziela 20 wrz 2015, 19:08
Posty: 362
zed pisze:
To chyba sprawka ostatniej aktualizacji.



masz jakieś dowody na potwierdzenie tej tezy czy to raczej twoje "gdybanie".

Sam wyżej napisałem że ludzie mają raczej dobre opinie w sprawie tej aktualizacji.
Samo "chyba" mi "chyba" nie naprawi problemu ;)

_________________
Mavic Pro Platinum Combo


Na górę
 Wyświetl profil  
 
Post: wtorek 10 lip 2018, 07:00 
Offline

Rejestracja: piątek 27 mar 2015, 11:37
Posty: 210
Po ostatniej aktualizacji po raz pierwszy zaczął mi zanikać podgląd.
Edit.
Chyba jednak to sprawka zaktulizowanej DJIGO4 do 4.2.20. Soft w Mavicu zmieniłem na .300 i nic to nie dało. Czy można jakoś zainstalowac starszą wersję?


Na górę
 Wyświetl profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 5 ] 

Strefa czasowa UTC+1godz.


Kto jest online

Użytkownicy przeglądający to forum: Google [Bot] i 3 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
Technologię dostarcza phpBB® Forum Software © phpBB Group

Strona korzysta z plików cookie w celu realizacji usług zgodnie z . Polityką prywatności
Możesz określić warunki przechowywania lub dostępu do cookie w Twojej przeglądarce lub konfiguracji usługi.