Zanim...
Zanim...

Zanim...


Polskie Forum FPV

Forum modelarzy i pilotów FPV
Dzisiaj jest niedziela 28 maja 2017, 17:28


Strefa czasowa UTC+1godz.




Nowy temat Odpowiedz w temacie  [ Posty: 7 ] 
Autor Wiadomość
Post: środa 12 paź 2016, 19:29 
Offline
Awatar użytkownika

Rejestracja: czwartek 16 gru 2010, 19:40
Posty: 916
Lokalizacja: Rzeszów
Wpadł mi ostatnio w łapki Zennmuse H3-3D. Wszystko fajnie tylko po uruchomieniu zachowuje się podobnie jak na linkowanym filmie.

https://www.youtube.com/watch?v=bs9ANFSMBU4

Miał ktoś może podobny przypadek bądź wie co może być przyczyną ? Wizualnie wszystko wydaje się być OK. Nie znam jego historii i nie wiem czy jest po crashu. Z brakujących elementów można wnioskować, że coś tam mu się przytrafiło. Może to być z winy uszkodzonego sensora halla, IMU czy jeszcze czegoś innego ? Szarpania są we wszystkich kierunkach więc raczej sterowanie silnikami jest w porządku.
Robiony był hard reset i ponowne wgranie softu ale nic to nie dało.

Ewentualnie komu oddać do naprawy albo przynajmniej wyceny czy i za ile da się go zreanimować ?

_________________
Pozdrawiam
Krzysiek


Na górę
 Wyświetl profil  
 
Post: środa 12 paź 2016, 20:09 
Offline
Awatar użytkownika

Rejestracja: poniedziałek 01 lut 2010, 11:29
Posty: 9980
Lokalizacja: Mikoszewo
pilot pisze:
nie wiem czy jest po crashu.

Prawdopodobnie jest. Taki efekt widziałem w dwóch przypadkach - po tym jak gimbal oberwał betonowym parkingiem i po mało umiejętnie wykonanej naprawie jednej z osi. Zenmuse jest na swego rodzaju enkoderach (osie silników przechodzą przez coś co wygląda jak potencjometr), jak mu się odczyty z enkoderów nie zgadzają ze wskazaniami IMU to dostaje jobla jak na załączonym wideo. Niezgodność odczytów może być spowodowana tym że:
-IMU oberwało i podaje głupoty
-któryś z enkoderów oberwał i j.w.
-w wyniku nieumiejętnej naprawy (lub uderzenia) oś jednego z silników jest w innej pozycji niż spodziewana (możesz to sobie wyobrazić tak jakbyś trzymał półkę na kamerę w miejscu i na siłę przekręcił silnik od PITCH. IMU pokazuje że jest prosto a enkoder zgłasza pochylenie)
-rama gimbala jest pogięta i czujniki fizycznie nie mogą dość równowagi.

Szanse naprawy są ale nieszczególnie wielkie. Raz mi się ta sztuczka udała, drugi raz musiałem wołać na pomoc DJI.

_________________
Ten wredny...


Na górę
 Wyświetl profil  
 
Post: środa 12 paź 2016, 21:06 
Offline
Awatar użytkownika

Rejestracja: czwartek 16 gru 2010, 19:40
Posty: 916
Lokalizacja: Rzeszów
Przeglądałem trochę różnych filmów i znam budowę. Osie z silników są szlifowane więc te enkodery trzeba przestawić o 180 st. aby dało się poprawnie złożyć więc przy naprawie możliwe ale trochę trudne przypadkowe przestawienie. Poza tym czy przestawienie jednej osi spowoduje taki efekt ? Jeśli tak to konstrukcja dość "zagmatwana" :-)

Czy w jakiś prosty sposób da się stwierdzić czy to IMU, czy faktycznie przestawiony enkoder ? Prawdopodobnie da się pominąć oś YAW przez wpięcie zewnętrznej tasiemki w drugie złącze przy elektronice ROLL. Wtedy zostałyby do ustawiania tylko 2 osie. Później można próbować przestawić enkodery o 180 w prawo i lewo zakładając, że nikt ich więcej nie obracał. Hmm, może spróbuję. Wprawdzie trochę zabawy ale może akuratnie się uda.

Przywalenie w beton pozostawiłoby jakieś otarcia, tu nic nie widać więc co najwyżej upadek był na miękkie podłoże.

_________________
Pozdrawiam
Krzysiek


Na górę
 Wyświetl profil  
 
Post: środa 12 paź 2016, 21:20 
Offline
Awatar użytkownika

Rejestracja: poniedziałek 01 lut 2010, 11:29
Posty: 9980
Lokalizacja: Mikoszewo
pilot pisze:
Osie z silników są szlifowane

Niezupełnie. Masz tam takie plastikowe nakładki na osie które przechodzą przez enkodery. I to właśnie tu powstaje problem. Poza tym porównaj sobie średnicę tego co przechodzi przez enkoder i co wchodzi w półkę kamery czy ramię gimbala ze średnicą tego co widać na środku rotora silnika. Ośki silników są cieniutkie jak zapałki. Na nie są nakładane masywne zacięte nakładki i to może się przemieścić.
I tak - przestawienie tylko jednej osi może powodować taki efekt. U mnie to był PITCH.

pilot pisze:
Czy w jakiś prosty sposób da się stwierdzić czy to IMU, czy faktycznie przestawiony enkoder ?

Nie znam :oops: Miałem do dyspozycji dwa gimbale uszkodzone w różny sposób i to znacznie ułatwiło dojście co jest co.

pilot pisze:
Prawdopodobnie da się pominąć oś YAW przez wpięcie zewnętrznej tasiemki w drugie złącze przy elektronice ROLL. Wtedy zostałyby do ustawiania tylko 2 osie.

Odcięcie elektroniki silnika którejkolwiek z osi powoduje wyłączenie całego gimbala.

_________________
Ten wredny...


Na górę
 Wyświetl profil  
 
Post: środa 12 paź 2016, 21:35 
Offline
Awatar użytkownika

Rejestracja: czwartek 16 gru 2010, 19:40
Posty: 916
Lokalizacja: Rzeszów
W takim razie są 3 opcje:
- próbować przestawiać enkodery z nadzieją, że trafi się na właściwą pozycję - raczej dość żmudne :-) ,
- dać gdzieś do naprawy,
- opchnąć na części - mechanicznie jest w porządku, silniki raczej dobre, elektronika chyba również więc jako dawca organów może się przydać.

Na pewno prościej byłoby wiedząc, że IMU jest sprawne. Tu nie ma takiej pewności więc dodatkowy niepewny element.

A po resecie i ponownym wgraniu softu enkodery nie przyjmują czegoś w rodzaju zerowych pozycji ?

W każdym razie wiem już co może być przyczyną takiego zachowania.

_________________
Pozdrawiam
Krzysiek


Ostatnio zmieniony środa 12 paź 2016, 21:40 przez pilot, łącznie zmieniany 1 raz

Na górę
 Wyświetl profil  
 
Post: środa 12 paź 2016, 21:40 
Offline
Awatar użytkownika

Rejestracja: poniedziałek 01 lut 2010, 11:29
Posty: 9980
Lokalizacja: Mikoszewo
Ad.1 Jestę modelarzę czy nie jestę? :mrgreen: Modelarzę są cierpliwę...
Ad.2 Ktoś tu wrzucał jakiś zakład specjalizujący się w wynalazkach DJI - nie Matulek przypadkiem...?
Ad.3 Próbowałem. Lepiej wyszedłem na Ad.1 bo poświęcając trochę czasu miałem w końcu 2 działające gimble a części to każdy chciał żebym niemal za darmo oddał.

_________________
Ten wredny...


Na górę
 Wyświetl profil  
 
Post: środa 12 paź 2016, 22:06 
Offline
Awatar użytkownika

Rejestracja: czwartek 16 gru 2010, 19:40
Posty: 916
Lokalizacja: Rzeszów
Naprowadziłeś mnie na temat i właśnie szukałem info. Znalazłem film, gdzie pokazane jest dość dokładnie jak ma być ustawiona oś silnika, a w zasadzie faktycznie pogrubiającej szlifowanej nakładki. Widać, że gość obraca tą nakładkę i ustawia prawidłowo. Może warto więc rozważyć pkt. 1 czyli rozbiórka i sprawdzenie jak jest u mnie :-)

Nawet żmudne dłubanie zostanie wynagrodzone jak gimbal ożyje, a ile satysfakcji i nowej wiedzy :mrgreen:

Chyba jutro trochę przy nim posiedzę i zobaczymy jaki efekt.

EDIT 13.10:
Porozbierałem i przestawiłem element z tworzywa. Okazuje się, że tylko oś PITCH można przestawić. Z silnika ROLL wychodzi oś pogrubiona i szlifowana z jednej strony. Podobnie ma pewnie YAW. Konstrukcja gimbala uniemożliwia zły montaż w tych osiach.
Poprawa PITCH przyniosła tylko częściowy sukces :-) Gimbal przestał wariować jednak oś PITCH zachowuje się dość dziwnie. Wychyla się w dół, drży po czym silnik jakby zwalniał trzymanie tej osi i sytuacja się powtarza. Czasem jakby ta oś wykonywała samoistnie ruchy. Niestety nie mam kamery GP i testowałem na sztucznym obciążeniu możliwe, że to jest powodem. Przy próbie obrotu czuć trzymanie, kamera ustawia się lekko w dół. Z kolei oś ROLL działa jak YAW - podąża za wychyleniem gimbala zamiast stabilizować.
Spróbuję jeszcze zrobić ponownie hard reset, może problem zniknie.

EDIT 19.10:
Problem z gimbalem rozwiązany, udało się naprawić. Po założeniu innej kamery wyważenie nie jest za dobre ale gimbal zachowuje się poprawnie. Robi autokalibrację, daje się sterować.

Podziękowania dla Verida za pomoc i naprowadzenie. Dodatkowe przeszukanie neta i działa :-)

_________________
Pozdrawiam
Krzysiek


Na górę
 Wyświetl profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 7 ] 

Strefa czasowa UTC+1godz.


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 3 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
Technologię dostarcza phpBB® Forum Software © phpBB Group

Strona korzysta z plików cookie w celu realizacji usług zgodnie z . Polityką prywatności
Możesz określić warunki przechowywania lub dostępu do cookie w Twojej przeglądarce lub konfiguracji usługi.