Zanim...
Zanim...



Polskie Forum FPV

Forum modelarzy i pilotów FPV
Dzisiaj jest poniedziałek 09 gru 2019, 00:11


Strefa czasowa UTC+1godz.


Regulamin forum


Kliknij, aby zapoznać się z regulaminem



Nowy temat Odpowiedz w temacie  [ Posty: 9 ] 
Autor Wiadomość
Post: wtorek 22 paź 2019, 18:01 
Offline

Rejestracja: środa 01 maja 2019, 14:08
Posty: 54
Lokalizacja: Częstochowa
Chciałbym zmienić kierunek obrotu silników przez BLHeli32 w Racerstar Metal. Podłaczyłem 4 przewody z ESC oraz masowy do Pixhawka. Program po kliknięciu Connect wyświetla komunikat o niepowodzeniu oraz żeby sprawdzić polaczenie/kabel USB.
Podłączyłem wszystko w takiej kolejności jak w poradniku, nawet sprawdzalem na takim samym ESC od znajomego i jest to samo.

Jaka może być przyczyna? Problem ze sterownikami w Win10??


Na górę
 Wyświetl profil  
 
Post: wtorek 22 paź 2019, 21:41 
Offline
Awatar użytkownika

Rejestracja: sobota 08 maja 2010, 09:43
Posty: 3993
Lokalizacja: Gliwice/Katowice
A podłączyłeś zasilanie do Esc? Z USB nie pójdzie.

_________________
samolot max 4579/1293
coper max 1729(na 5.8)


Na górę
 Wyświetl profil  
 
Post: wtorek 22 paź 2019, 22:21 
Offline

Rejestracja: środa 01 maja 2019, 14:08
Posty: 54
Lokalizacja: Częstochowa
Mam podłączone LiPo 6S do regulatora, oraz 4 przewody "sygnałowe" od ESC do Pixhawka oraz przewód masowy.
Podłączam kabel USB do Pixhawka (nie jest w tej chwili zasilany przez gniazdo POWER) i ani BLHeliSuite32 nie może się połączyć, ani aplikacja BetaFlight na Windows 10.
Przez Chroma też próbowałem i nic.

Obrazek


Na górę
 Wyświetl profil  
 
Post: środa 23 paź 2019, 10:14 
Offline
Awatar użytkownika

Rejestracja: sobota 08 maja 2010, 09:43
Posty: 3993
Lokalizacja: Gliwice/Katowice
A w ogóle ci działa sterowanie silnikiem z pixhawk?

_________________
samolot max 4579/1293
coper max 1729(na 5.8)


Na górę
 Wyświetl profil  
 
Post: środa 23 paź 2019, 11:33 
Offline

Rejestracja: środa 01 maja 2019, 14:08
Posty: 54
Lokalizacja: Częstochowa
Wyczytałem, że nie ma potrzeby kalibracji jeśli ESC ma DShot.
Nie, nie działa. Może spróbuje przeinstalować Windows. Możliwe, że on sterowniki blokuje i sprawdzę też na Pixhawku od znajomego...


Na górę
 Wyświetl profil  
 
Post: środa 23 paź 2019, 12:34 
Offline
Awatar użytkownika

Rejestracja: sobota 08 maja 2010, 09:43
Posty: 3993
Lokalizacja: Gliwice/Katowice
wątpię, sterowniki nie zmieniają sie bo gada po porcie szeregowym, nie masz pod ręką jakiegoś FC gdzie można betaflight zainstalować?
I jesteś pewnien, że nie pomyliłeś kabelków? Wyłącz ten od telemetrii.

_________________
samolot max 4579/1293
coper max 1729(na 5.8)


Na górę
 Wyświetl profil  
 
Post: środa 13 lis 2019, 23:19 
Offline

Rejestracja: środa 01 maja 2019, 14:08
Posty: 54
Lokalizacja: Częstochowa
Właśnie próbowałem na kolejnym Pixhawku i nadal jest to samo. Przez BLHeliSuite32 nie mogę się połączyć.
1. Nie powinno być czasem wszystko połączone do AUX OUT, zamiast do MAIN OUT? Gdzieś w dokumentacji tak pisało. Ale nie działa ani tak, ani tak. Polaryzacja kabelków jest na pewno dobrze.
2. Czy może być to uszkodzony ESC? Normalnie się świeci, jest lekko ciepły bez podłączonych silników, więc raczej wszystko ok.
3. Czy Pixhawk może mieć podłączone jednocześnie zasilanie poprzez gniazdo POWER z PDB, oraz przez kabel USB z laptopa?


Na górę
 Wyświetl profil  
 
Post: czwartek 14 lis 2019, 06:13 
Offline
Awatar użytkownika

Rejestracja: poniedziałek 27 sie 2018, 18:23
Posty: 177
Lokalizacja: Gdańsk
Moze.
A sprawdzales w dokumentacji czy nie trzeba w ustawieniach wyjsc cos przestawic?


Na górę
 Wyświetl profil  
 
Post: poniedziałek 02 gru 2019, 18:18 
Offline

Rejestracja: środa 01 maja 2019, 14:08
Posty: 54
Lokalizacja: Częstochowa
W końcu się udało, BLHeli32 Suite działa i kierunek obrotu silników można śmiało zmieniać.
Poniżej ustawienia, gdyby ktoś też miał problem z Racerstar Metal 60A. Poniżej dwa zdjęcia.

SERVO_BLH_MASK
channels9-12

SERVO_BLH_OTYPE
dshot150

SERVO_BLH_AUTO
enabled

MOT_PWM_TYPE
dshot150

SERVO1_FUNCTION - SERVO8_FUNCTION
disabled

SERVO9_FUNCTION - SERVO12_FUNCTION
Motor 1 - Motor 4


20191202_034425.jpg
20191202_034425.jpg [ 341.85 KiB | Przeglądany 53 razy ]
Na górę
 Wyświetl profil  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 9 ] 

Strefa czasowa UTC+1godz.


Kto jest online

Użytkownicy przeglądający to forum: MSN [Bot] i 9 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
Technologię dostarcza phpBB® Forum Software © phpBB Group

Strona korzysta z plików cookie w celu realizacji usług zgodnie z . Polityką prywatności
Możesz określić warunki przechowywania lub dostępu do cookie w Twojej przeglądarce lub konfiguracji usługi.